Dismiss Notice



Register Today It's free! This box will disappear once registered!

2000 Explorer. Speedometer issue.

Discussion in 'Stock 1995 - 2001 Explorers' started by shaddydozer, July 16, 2011.

^^Searches ExplorerForum.com^^
  1. shaddydozer

    shaddydozer New Member

    Joined:
    July 16, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    mi
    Year, Model & Trim Level:
    2000 exploere eddie bauer
    my speedometer quit working and once in a while it will start working again what could be wrong
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.

  3. BrooklynBay

    BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

    Joined:
    November 11, 2005
    Messages:
    53,027
    Likes Received:
    321
    Trophy Points:
    113
    City, State:
    Brooklyn, NY
    Year, Model & Trim Level:
    88 89 93 95 96 Aerostars
    Welcome to this forum! I've moved your thread into the stock 95-01 section. You might have a bad connection in the cluster. Remove the panel, and check the solder connections.
     






We Support Our Troops!