Dismiss Notice



Register Today It's free! This box will disappear once registered!

2002 Idle Problem and 4 Codes

Discussion in 'Stock 2002 - 2005 Explorers' started by Ryker1, March 17, 2013.

^^Searches ExplorerForum.com^^
  1. Ryker1

    Ryker1 New Member

    Joined:
    February 24, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 XLT Sport 4x4 4.0L
    My 2002 Explorer Sport XLT 4x4 4.0L has developed an idle problem. It starts fine when cold and after a five minute warm up it begins to idle up and down and then eventually stalls. It can be driven but acts the same when my foot is off the accelerator pedal.

    Previously, the check engine light came on and I've had a local garage do a fault code retrieval (check engine light) and they come up with these codes:

    P0102 MAF Signal Low Input to PCM
    P1152 Lack of Upstream Heated Oxygen Sensor Switch - Sensor Indicates Rich - Bank 2
    P1132 Lack of Upstream Heated Oxygen Sensor Switch - Sensor Indicates Rich - Bank 1
    P1451 EVAP Control System Canister Vent Solenoid Circuit Malfunction

    They suggested that I needed new O2 Sensors and gave me a hefty quote.

    After reading some forum threads and noticing that my air filter container was unclipped and open, I replaced my air filter, cleaned my Idle Air Control Valve and cleaned my MAF Sensor. Same issue but slightly better idle. I decided to buy a new IAC Valve and this had no effect.

    Any ideas where to go from here? Also, where do I find my EVAP Control System Canister Vent Solenoid and how do I troubleshoot it?
     
    Last edited: March 17, 2013
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.
  3. Ryker1

    Ryker1 New Member

    Joined:
    February 24, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 XLT Sport 4x4 4.0L
    Any Ideas?

    Please, can anyone help me with this.
     
  4. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,888
    Likes Received:
    7
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Welcome aboard!! :salute:

    You will probably get better results posting in the

    Stock 1995 - 2001 Explorers Sub Forum
    Questions related to non-modified 1995-2001 Explorer, Mountaineer, Ranger and '02+ Sports and Sport Trac. Problem solving, maintenance, TSB, service bulletins, owner reviews, specifications.

    Your '02 Sport is covered there.

    Good luck & Happy Exploring. :biggthump
     
  5. Ryker1

    Ryker1 New Member

    Joined:
    February 24, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 XLT Sport 4x4 4.0L
    Thanks for the tip, BigRondo
     
  6. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,888
    Likes Received:
    7
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    You're welcome. Good luck getting it sorted!!
     






We Support Our Troops!