Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

2006 Explorer Radio Wont Turn On

Discussion in 'Explorer Audio & Navigation' started by TheBigOC868, December 15, 2014.

^^Searches ExplorerForum.com^^





  1. TheBigOC868

    TheBigOC868 New Member

    Joined:
    December 15, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Denver, CO
    Year, Model & Trim Level:
    2006 Explorer
    Hello all,

    I recently had an alternator replaced as well as a new battery on my 2006 Explorer.
    After the alternator was replaced, the only electrical issue I had was with my Kenwood Radio not turning on. I've got a KDC-X595. I checked all of the fuses, and none are blown.
    Is there anywhere else I can look to troubleshoot? Has anyone run into this issue as well and can lend me a best idea of what might have happened?

    Thank you!!!
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. DjDom

    DjDom Moderator Emeritus

    Joined:
    September 11, 2011
    Messages:
    2,621
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    Toronto, Ontario
    Year, Model & Trim Level:
    97 XL(imited)
    May sound silly, but did you check the fuse on the actual head unit?
    That headunit has a 10 amp fuse on the back of it. Sounds like that blew.
     
  4. TheBigOC868

    TheBigOC868 New Member

    Joined:
    December 15, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Denver, CO
    Year, Model & Trim Level:
    2006 Explorer
    I did not check that, but thank you for pointing that out.
     
  5. DjDom

    DjDom Moderator Emeritus

    Joined:
    September 11, 2011
    Messages:
    2,621
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    Toronto, Ontario
    Year, Model & Trim Level:
    97 XL(imited)
    No problem. That's most likely the issue if the other fuses are good.
     

Share This Page







We Support Our Troops!