Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

2008 XLT power steering issues

Discussion in 'Stock 2006 -2010 Explorers' started by G-1911, May 31, 2017.

^^Searches ExplorerForum.com^^





  1. G-1911

    G-1911 New Member

    Joined:
    January 20, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Gerogia
    Year, Model & Trim Level:
    2008 Explorer XLT
    Hello everyone-

    I have a problem I am hoping you can help with. My 2008 2wd 4.0l XLT is having a strange power steering issue. When I start the truck and back out of my driveway it feels like I have no power steering. Within about ten seconds of putting the truck in reverse the "check charging system" warning comes on the dash. As long as it is on I have no power steering. That warning stays on for about 15-20 seconds and then goes away. As soon as it goes away power steering is restored.

    I have checked my battery and it is good, it is also pretty new. The power steering fluid level is good. Based on another thread that seemed to have a similar issue I replaced the serpentine belt, the idler pulley and the belt tensioner. No changes at all to the issue.

    My next step is to replace the power steering pump but I thought I would check to see if anyone had any input first. Thanks!
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Rcflyer330

    Rcflyer330 Active Member

    Joined:
    March 23, 2014
    Messages:
    526
    Likes Received:
    23
    Trophy Points:
    28
    City, State:
    Michigan
    Year, Model & Trim Level:
    2010 Ford Explorer XLT V6
    Well before you change the pump I would look into the check charging system warning. When the light is on does the engine sound like it is had a load on it?
     
  4. G-1911

    G-1911 New Member

    Joined:
    January 20, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Gerogia
    Year, Model & Trim Level:
    2008 Explorer XLT
    The engine sounds like normal at idle. RPMs are steady and normal as well.
     

Share This Page







We Support Our Troops!