Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

2017 Platinum Surging and Stalling

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by yooper89, October 19, 2016.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. yooper89

    yooper89 New Member

    Joined:
    April 4, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2013 Ford Explorer
    Sorry for the long post, please be patient....

    Brand new, less than 200 miles on it when this problem started. Noticed at first when driving through the parking lot on day one. Seemed like a trans shifting problem, switching between gears. This is not the same as the problem others have mentioned with cold starts, restarts etc, when it surges for a short time after starting. I had a 2014 sport that did that for three years. This is different.

    Same strange "feel" on expressway in cruise. Slowed down behind a vehicle automatically, and then the engine felt like it died right on the highway. I downshifted with the paddles and it seemed to recover. Made me think transmission again.

    Got off the expressway and in sport mode would not shift between 3rd and 4th, surged greatly, and then I went back to drive and it was ok again. Stopped at a light a mile down the road, and then when it turned green, in drive, no power at all. Had to feather the gas to get through the intersection. Got home OK.

    Recreated the problem that night when playing around shifting in sport mode. Stopped a light this time, and with food on the brake, it was surging at the light, like it wanted to pull away. Kept doing this as I pulled into a lot, and in 1st, drive and in park, the engine just surged about 500 RPM up and down. Shut off, restart and it is fine.

    Recreated again on way home. This time engine stalled and would not restart for a few minutes. Got it started and drove it to the dealer.

    They say it is a "Fuel Rail Pressure Sensor". On backorder until 10/25. Dealer says it is a redesigned part, not yet released. This seems like a big deal. If it comes in on the 25th, that will be two weeks without my brand new $50K vehicle. Very upset, and not convinced they will fix it.

    Anyone else experiencing this type of problem?
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. 613GT500

    613GT500 Well-Known Member

    Joined:
    September 28, 2015
    Messages:
    1,528
    Likes Received:
    106
    Trophy Points:
    73
    City, State:
    Ontario, Canada
    Year, Model & Trim Level:
    2016 XC90 T8 R-Design
    Must be a major issue, if they are redesigning the sensor.
     
  4. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,710
    Likes Received:
    1,285
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve II
    Callsign:
    VE3
    I think it's time to update your profile top show 2017 Platinum.

    Peter
     
  5. Jon H

    Jon H New Member

    Joined:
    October 19, 2016
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Wilbraham, MA
    Year, Model & Trim Level:
    2017 Explorer Platinum

Share This Page







We Support Our Troops!