1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

5r55e help

Discussion in 'Elite Explorer 911!' started by Ozonkiller, December 23, 2004.

  • Searches ExplorerForum.com
    1. Ozonkiller

      Ozonkiller New Member

      Joined:
      May 13, 2003
      Messages:
      29
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Waddell, AZ
      Year, Model & Trim Level:
      '97 XLT
      '97 Explorer 4.0 with Control trac 4wd. First a little history. At about 50K miles found the dipstick and thusly the pan full of rust :eek: The fluid looked like mud. It was a mess. A thorough flush, several in a row actually, and was back on the road. Never really figured that one out. No trans cooler leak. Never been in more than a heavy rain.
      110K miles, blinking OD light, the torque converter lockup solenoid fell out of the valve body. Fixed that along with a blown valve body gasket and ultimately a new torque converter. An impromptu flushing was done as each step, the solenoid, gaskets and TC involved a pan removal, each time thinking " I've got it". Ultimately the light stayed out and life was good.
      Today the daughter informs me that the truck stalls when put in reverse. Indeed, put it in any gear and it seems OK but put it in reverse and the engine labors and the vehicle shudders as if the trans is dragging. Pulled the stick and it is covered in rust :confused: , the fluid seems good in color but stinks to high heaven.
      I'm pretty much resigned to the fact that this thing is toast and I'm willing to hit up Phoenix Remanufactured Transmissions with a new one, but I'd like a little input before I jump into this.
      OK, Jump in guys. Thanks!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. TPLYNCH

      TPLYNCH Well-Known Member

      Joined:
      November 19, 1999
      Messages:
      3,196
      Likes Received:
      2
      Trophy Points:
      0
      City, State:
      Brewster, NY
      Year, Model & Trim Level:
      1999 XLS
      Do the 5R's have the low/reverse servo, or was that an A4LD issue? If it was the TC, I'd think you'd have problem in D as well. Try another flush and filter change first?
       

    Share This Page







    We Support Our Troops!