Dismiss Notice



Register Today It's free! This box will disappear once registered!

86 ranger won't start

Discussion in 'Ford Ranger - Mazda B-Series Forum' started by califjeff, June 28, 2011.

  • Searches ExplorerForum.com
    1. califjeff

      califjeff New Member

      Joined:
      December 27, 2006
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      placerville, calif.
      Year, Model & Trim Level:
      1993 Explorer
      I have an 86 ranger 2.9L. 5spd.
      The motor cranks over fine but won't start. Has spark, Fuel is coming out of the Schrader valve when (not a steady stream will flow them stop and start again) I open it with the power on. But the fuel pump relay is making a lot of clicking noises and also when it's been sitting for awhile I can start it with starting fluid and it will run for about 20 to 40 seconds or so but after that it won't start even with starting fluid and the eec relay clicks sometimes when i turn the key on. I shop told my friend that it was getting to much fuel but doesn't seem that way to me.
      Totaly lost on this one.
      Jeff
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    Share This Page







    We Support Our Troops!