Dismiss Notice



Register Today It's free! This box will disappear once registered!

91 x electrecle problem

Discussion in 'Stock 1991 - 1994 Explorers' started by 1991explorerEB, March 11, 2012.

  • Searches ExplorerForum.com
    1. 1991explorerEB

      1991explorerEB New Member

      Joined:
      January 1, 2012
      Messages:
      36
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      1991 ford explorer EB
      so i only have back brake lights off and on, same with the blinkers. so i checked the fuse that had those on it and it said it was a 15 amp in the manuel, but the fuse was a 30amp. i later found out that the guy i bought it from had ran another tow package includng a brack controller to the trunk area. so they thought that by putting a new circut of that same fuse, they would need a 30 amp?. also he hooked up a remote start and did a really bad job. by bad job i mean using electrical tape and wire nuts to tie together wires. the thing is, he split the original ciruct for brakes, blinkers and flashers, to another towe packege all the way to the back...... I need help with this. any1 know wht it could be? my car isnt street ready of course cause i have wires all over!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    Share This Page







    We Support Our Troops!