1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

92' EB Won't start Battery tested good

Discussion in 'Elite Explorer 911!' started by AJCarolla, December 8, 2004.

  • Searches ExplorerForum.com
    1. AJCarolla

      AJCarolla New Member

      Joined:
      November 4, 2004
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Reno, Nevada
      Year, Model & Trim Level:
      92 EB
      I have a 92' Eddie Baur, would not start, negative battery cable was corroded very badly all the way down the wire. I replaced cable and it still won't start. I had the battery tested and it is fine. Do not believe it is the alternator, but will have it tested. Any other suggestions??? Anything will help, thanks alot.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. N2MUDN91

      N2MUDN91 Active Member

      Joined:
      August 22, 2002
      Messages:
      903
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Lee's Summit, Missouri
      Year, Model & Trim Level:
      2005 Ranger
      Do you get any clicking, or cranking of the motor? Or do you have nothing at all?

      Shane
       
    4. AJCarolla

      AJCarolla New Member

      Joined:
      November 4, 2004
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Reno, Nevada
      Year, Model & Trim Level:
      92 EB
      It will click, I've gotten it to start but after about 10 mins of driving voltage drops, and headlights go out, in dash battery light stays on no matter what though. Volt gauge goes all the way down. The more I think about it it sounds like an alternator. What do you think?
       
    5. TPLYNCH

      TPLYNCH Well-Known Member

      Joined:
      November 19, 1999
      Messages:
      3,196
      Likes Received:
      2
      Trophy Points:
      0
      City, State:
      Brewster, NY
      Year, Model & Trim Level:
      1999 XLS
      That's alternator.
       
    6. DeRocha

      DeRocha NEX Vice President Elite Explorer Moderator Emeritus

      Joined:
      July 5, 2003
      Messages:
      6,662
      Likes Received:
      19
      Trophy Points:
      48
      City, State:
      Brockton, MA
      Year, Model & Trim Level:
      '93 XLT 4x4
      Alternator...
       

    Share This Page







    We Support Our Troops!