Dismiss Notice



Register Today It's free! This box will disappear once registered!

94 explorer no power/ rt bank plugs burning up

Discussion in 'Stock 1991 - 1994 Explorers' started by tinysmith, March 12, 2015.

  • Searches ExplorerForum.com
    1. tinysmith

      tinysmith New Member

      Joined:
      March 12, 2015
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      1994 ford explorer
      No codes. Have replaced IAT, ECT and TPS. New plugs and wires 10,000 miles ago. Started runing rough. Checked plugs and rt bank plugs burnt off. Replaced those plugs. 500 miles later, running rough, checked plugs and rt bank plugs starting to deteriate again. Replaced and engine will hardly tach out now. Changed coil pack and MAF sensor from friends working Explorer and nothing changed. All vacumn lines appear to be good, fuel pressure checks out, injectors tested by listening by stethoscope. Their has also been engine knock problems with this motor. Please help as soon as possible as this is my work ride.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. 2stroke

      2stroke Elite Explorer

      Joined:
      August 7, 2013
      Messages:
      1,174
      Media:
      6
      Likes Received:
      34
      Trophy Points:
      68
      Location:
      55302
      City, State:
      Annandale, MN
      Year, Model & Trim Level:
      1993 Ford Explorer Sport
      Detonation in only bank 1? I would be highly suspicious of the bank 1 O2 sensor, but they often have a code. There are some other causes of detonation, but I can't think of anything else that could cause all 3 cylinders to act like that.
       
    4. larrydd999

      larrydd999 Elite Explorer

      Joined:
      December 14, 2010
      Messages:
      443
      Likes Received:
      14
      Trophy Points:
      18
      City, State:
      Port Angeles, WA
      Year, Model & Trim Level:
      92 XLT, 94 Limited
      I'm going to throw something out and ask for comments from those with much more experience... With a known engine knock, could it be something like an intake or exhaust gasket causing a fuel mixture issue?
       
    5. FR-425

      FR-425 Used to be a road here. Elite Explorer

      Joined:
      November 21, 2013
      Messages:
      2,629
      Media:
      1
      Likes Received:
      82
      Trophy Points:
      68
      City, State:
      Phoenix, AZ.
      Year, Model & Trim Level:
      1994 Explorer Limited
      Mine had a similar prob when I first bought it.

      The first CAT had melted into the second causing high EGT which was more severe on the right bank simply because it is closer to the CAT's.

      Right bank plugs showed evidence of running hotter than the right, and yes it spark knocked badly and had no power.
       
    6. murkinstock

      murkinstock Active Member

      Joined:
      April 8, 2013
      Messages:
      309
      Likes Received:
      8
      Trophy Points:
      18
      City, State:
      Salem, Oregon
      Year, Model & Trim Level:
      '99 Explorer Sport
      I second it being melted down Cats.
       

    Share This Page







    We Support Our Troops!