Dismiss Notice



Register Today It's free! This box will disappear once registered!

97 Explorer radio loses passenger side sound

Discussion in 'Stock 1995 - 2001 Explorers' started by russosborne, September 22, 2011.

^^Searches ExplorerForum.com^^





  1. russosborne

    russosborne Member

    Joined:
    August 29, 2011
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    6
    City, State:
    Glendale AZ
    Year, Model & Trim Level:
    2010 Subaru Forester
    I have a feeling it is a loose connection somewhere, but I am having an intermittent problem with the radio losing the passenger side stereo channel. Sometimes happens when going over a bump, turning steering wheel, even just driving along straight and no bumps. It even did it once when I was closing the driver's window (power).

    the radio is just the am/fm/cassette.

    Just wanted to check to see if there was some known issue before I start tearing into stuff.

    Thanks,
    Russ
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Steeda90GT

    Steeda90GT Active Member

    Joined:
    July 6, 2006
    Messages:
    448
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Central NJ
    Year, Model & Trim Level:
    99 Sport
    You know...I thought I was crazy, but I think I have the same problem. I even pulled the radio, and re-seated the connections to the back. I still think I have this issue. (I say think, cause Im not sure if it's the song being played in stereo or not)
     
  4. russosborne

    russosborne Member

    Joined:
    August 29, 2011
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    6
    City, State:
    Glendale AZ
    Year, Model & Trim Level:
    2010 Subaru Forester
    I am definitely losing the one channel. It just drops out completely. I am going to have to take it apart sooner or later I suppose. Trying to wait until I am ready to do some other stuff that needs the dash opened up. Maybe I should just listen to AM radio. :)
    Russ
     
  5. scucci

    scucci Active Member

    Joined:
    November 4, 2005
    Messages:
    696
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    98 Sport
    If you have rear controls, try working them and tapping on the rear of the console. I had some similar problems with my 98, then the radio just quit. It was a short in the rear controls causing the problems. I just by-passed them and wired directly from the head unit to the speakers.
     
  6. russosborne

    russosborne Member

    Joined:
    August 29, 2011
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    6
    City, State:
    Glendale AZ
    Year, Model & Trim Level:
    2010 Subaru Forester
    Thanks. don't have a clue if I have rear controls or not, but will take a look.
    Russ
     

Share This Page







We Support Our Troops!