1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

98 ex with mach system...no bass?

Discussion in 'Explorer Audio & Navigation' started by -=c=-, December 28, 2004.

  • Searches ExplorerForum.com
    1. -=c=-

      -=c=- New Member

      Joined:
      December 21, 2004
      Messages:
      46
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Tulsa, OK
      Year, Model & Trim Level:
      '98 Eddie Bauer V8 AWD
      Just got a 98 with the mach stereo with in dash cd/tape and the 6 disc in the center console.

      My question is does this thing have no bass or is mine broke? I cranked the bass to the top and still barely hear anything at all. Keep in mind I'm coming from a Bose system in a Maxima, so maybe I'm expecting too much.

      Does the rear hatch sub (if that's what is there, I haven't opened it yet) have any bass at all? How can I check anything out (I'm not an audio expert).
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. '96explorereddiebauer

      '96explorereddiebauer Well-Known Member

      Joined:
      June 11, 2000
      Messages:
      3,757
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Clemmons, NC
      Year, Model & Trim Level:
      '06 Honda Accord EX-L
      The sub is probably blown or the subamp is dead.

      Heh...since you're coming from a Maxima's Bose system, don't have too high expectations on the Explorer systems because they suck even though they're Mach or JBL. Heh...my Acura's base system sounds a whole lot better than my Explorer's JBL system.
       
    4. zeeman

      zeeman New Member

      Joined:
      May 24, 2002
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Loomis, CA
      Year, Model & Trim Level:
      98 EddieB 4X4 4.0 auto
      I have a eb explorer with the mach system too. There is a ton of bass from the sub in the far back storage area. The sub with amp is $313. it wiil sound great when you get yours online. I am trying to find a replacement which is cheaper but no luck so far. I am going to make a new post if I cannot find an existing post.
       
    5. boominXplorer

      boominXplorer Elite Ranger Elite Explorer

      Joined:
      September 16, 2002
      Messages:
      8,477
      Media:
      55
      Albums:
      3
      Likes Received:
      373
      Trophy Points:
      103
      City, State:
      Virginia Beach, Va
      Year, Model & Trim Level:
      00 4x4 Mounty
      i have my whole stock setup for sale out of my 00 merc
       

    Share This Page







    We Support Our Troops!