Dismiss Notice



Register Today It's free! This box will disappear once registered!

98 XLT ECM troubles

Discussion in 'Stock 1995 - 2001 Explorers' started by salty4568, August 5, 2009.

  • Searches ExplorerForum.com
    Tags:
    1. salty4568

      salty4568 New Member

      Joined:
      July 31, 2009
      Messages:
      0
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Texas
      Year, Model & Trim Level:
      '98 XLT
      Howdy. We purchased a 1998 XLT Sport Explorer about two months ago. It is a 4.0, 2 door, auto tranny. The tranny started shifting hard between 2nd and 3rd as well as taking a long time to shift. It's been in the shop for almost three weeks now. They rebuilt the tranny completely, but are still trying to finish the job as it doesn't shift. They suspected a bad sensor, but then decided it was the ABS module. Then found signals were going as far as the ECM, so decided ECM was bad. They were supposed to have a replacement for that, but as we haven't heard from them today, wonder if that also did not work.

      What the heck is going on? If I had known about all the computer modules involved, we would have just found an old F150 from the 1970's.

      Any ideas? SHould I just tell the guys to forget it and look elsewhere? (Hate to - they are nice guys.) Can I even drive it? Will manual shift work at all?

      I'm confused and frustrated. Any help, please??

      Skip
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    Share This Page







    We Support Our Troops!