Dismiss Notice



Register Today It's free! This box will disappear once registered!

99 Eddie Bauer AWD No Horn, No Cruise Control,ABS Light On

Discussion in 'Stock 1995 - 2001 Explorers' started by mhersh2356, April 27, 2016.

  • Searches ExplorerForum.com
    Tags:
    1. mhersh2356

      mhersh2356 New Member

      Joined:
      July 16, 2009
      Messages:
      15
      Likes Received:
      1
      Trophy Points:
      3
      City, State:
      Orlando, Fl.
      Year, Model & Trim Level:
      1999 Eddie Bauer V8 AWD
      Need Help! First my Cruise Control stopped working. Then the Horn stopped working. Now the ABS light is constantly on and the check engine light is on showing a PO500 code. Also my rear wiper motor lost power. I have replaced both front hubs and we think the connections are fine. Is there a relay or control module that handles all these or do I have multiple issues? 1999 Explorer Eddie Bauer AWD 277,000 Miles. Thanks!:(
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    3. MillerAPF97XLT

      MillerAPF97XLT Member

      Joined:
      January 2, 2016
      Messages:
      81
      Likes Received:
      0
      Trophy Points:
      6
      City, State:
      Branson, MO
      Year, Model & Trim Level:
      1997 Explorer XLT
      As for the horn, cruise and ABS light, it sounds like that may all be related to a broken clockspring in the steering wheel. Got a '97 XLT myself, and no manual for it, but this happened to me with my '94 F150 a ways back. I was able to cut off the broken piece, re-make the fold, re-center the clockspring and reinstall the wheel. That was several years ago, and it has even survived being in my son's possession for a while.
       
    4. mhersh2356

      mhersh2356 New Member

      Joined:
      July 16, 2009
      Messages:
      15
      Likes Received:
      1
      Trophy Points:
      3
      City, State:
      Orlando, Fl.
      Year, Model & Trim Level:
      1999 Eddie Bauer V8 AWD
      Thanks MillerAPF97XLT. I will look into that clock spring lead. Just today the heater control module went bad and I lost all the coolant of course. Luckily it happened in front of a friend's house so we went and got a new one at the parts store and that was a quick fix. It's never is that easy is it? Right on top of the motor and very easy to fix. Then I scored BIG at a junk yard today with a .........PERFECT center console lid! How hard are they to find????? $15 bucks later and it was installed on my truck. Lucky day today! Now back to the original problem.
       

    Share This Page







    We Support Our Troops!