Dismiss Notice



Register Today It's free! This box will disappear once registered!

99 Ford Explorer Engine Stalling

Discussion in 'Elite Explorer 911!' started by kevinisin, December 19, 2004.

^^Searches ExplorerForum.com^^
  1. kevinisin

    kevinisin New Member

    Joined:
    December 19, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Mobile, Alabama
    Year, Model & Trim Level:
    1999 Ford Explorer 4.0
    I have a 1999 Ford Explorer with the V6 4.0 Engine, my problem is while driving various speeds 0-60, the engine just stops, this has happened at least 10 times. I pull over and most of the time it starts right back up every once in awhile I have to sit there for a few minutes. I get home and it runs fine, I changed the fuel filter and Idle Air Control valve. Does anyone have any advice or maybe has had this problem and knows a solution.

    Thanks
    Kevin
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. aldive

    aldive Elite In Memoriam

    Joined:
    January 17, 2001
    Messages:
    24,719
    Likes Received:
    6
    Trophy Points:
    0
    Year, Model & Trim Level:
    1999 XLT
    Has your CEL illuminated?
     
  4. kevinisin

    kevinisin New Member

    Joined:
    December 19, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Mobile, Alabama
    Year, Model & Trim Level:
    1999 Ford Explorer 4.0
    Po 320

    Yes and I'm getting a PO 320 Code - Engine\Dist. malfuntion, I don't get it everytime it dies however.
     
  5. Eneurb

    Eneurb Active Member

    Joined:
    December 19, 2004
    Messages:
    707
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Ajax, Ontario, Canada
    Year, Model & Trim Level:
    1998 Limited
    Is it an OHV or SOHC??? Sounds like a crank or cam sensor problem... For the odd times that the engine does not restart right away, observe the "Check Engine" light, if it is illuminated while the engine is cranking, that means that the PCM is not recieving a crank signal.
     
  6. kevinisin

    kevinisin New Member

    Joined:
    December 19, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Mobile, Alabama
    Year, Model & Trim Level:
    1999 Ford Explorer 4.0
    Engine stalling

    It is an OHV. Thanks for the tip about the CEL when starting, I did not know that, I will check the next time it happens.

    Thanks again and any other information will be greatly appreciated.

    Kevin
     
  7. Eneurb

    Eneurb Active Member

    Joined:
    December 19, 2004
    Messages:
    707
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Ajax, Ontario, Canada
    Year, Model & Trim Level:
    1998 Limited
    It only works on OBDII systems...
     






We Support Our Troops!