Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

A/c compressor running but not cycling on and off

Discussion in 'A/C & Heater systems - HVAC' started by 1hicj7, July 23, 2016.

^^Searches ExplorerForum.com^^





  1. 1hicj7

    1hicj7 New Member

    Joined:
    December 20, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Kansas City,KS
    Year, Model & Trim Level:
    1991
    For the past couple months, I've noticed my a/c compressor has NOT been cycling on and off. I drive a 1991 Explorer with a system I replaced and retrofitted several years ago. I cannot remember in the past if it ever did cycle on and off or if it ran all the time. According to my gauges it's at 44PSI and the temp is 93 degrees but the weather channel says it "feels like" 103 degrees (I dont know which I should go by).
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Semperfi96

    Semperfi96 Member

    Joined:
    June 7, 2016
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    Madison al
    Year, Model & Trim Level:
    2001 xlt
    Have you replaced the ac cycling switch on the fire wall yet. Not sure on a 91 but just call a parts store and make sure it does have one. I know ford's are bad about having them and they go out
     
  4. 1hicj7

    1hicj7 New Member

    Joined:
    December 20, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Kansas City,KS
    Year, Model & Trim Level:
    1991
    no I have not... I'll look into it!
     

Share This Page







We Support Our Troops!