Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

A/C vent or vents feel clogged.

Discussion in 'Stock 2002 - 2005 Explorers' started by XLTyler83, September 4, 2019.

^^Searches ExplorerForum.com^^





  1. XLTyler83

    XLTyler83 Member

    Joined:
    April 15, 2016
    Messages:
    68
    Likes Received:
    11
    Trophy Points:
    8
    City, State:
    Myrtle Beach SC
    Year, Model & Trim Level:
    2004 XLT 4x4 Loaded
    I was just wondering anyone could put their two cents in I do not have an air filter or anything like that that is able to get clogged so it makes me believe something is clogged along the air duct system because I have a new blower motor my A/C system runs great it does blow cold air and on 4 the blower motor makes the normal amount of noise air is cold through the vents and it’s trying but the flow isn’t what it used to be, has anyone had debris clog their HVAC system before? Like I said I had My A/C recharged in the spring I am almost 99% it’s not mechanical but something clogging the airway under the dash
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. XLTyler83

    XLTyler83 Member

    Joined:
    April 15, 2016
    Messages:
    68
    Likes Received:
    11
    Trophy Points:
    8
    City, State:
    Myrtle Beach SC
    Year, Model & Trim Level:
    2004 XLT 4x4 Loaded
    Also possibly a blend door or a duct that has closed and remain closed and needs to be opened manually?
     
  4. Number Twelve

    Number Twelve Active Member

    Joined:
    August 31, 2015
    Messages:
    497
    Likes Received:
    76
    Trophy Points:
    38
    City, State:
    15 miles west of Tampa Florida
    Year, Model & Trim Level:
    2005 Ford Explorer XLT
    There is an outdoor air flap that falls down and blocks the motor. It is in front of the passengers knees. We never use outdoor air in Florida so somebody had already installed an external outdoor air blocker. Just a piece of plastic screwed over the hole under the front cowling (under the windshield wipers). When I found the fallen flap, I frisbee'd it. There is the possibility of dirt in the evaporator coil. Once upon a time, I found one with so much crud that mushrooms were growing in it! More likely is a failure in an air flap modulator motor, but mine failed in the rear A/C so I haven't been into the front A/C gizmos.
     
  5. XLTyler83

    XLTyler83 Member

    Joined:
    April 15, 2016
    Messages:
    68
    Likes Received:
    11
    Trophy Points:
    8
    City, State:
    Myrtle Beach SC
    Year, Model & Trim Level:
    2004 XLT 4x4 Loaded
    Much appreciated! Mushrooms thing is crazy I sure hope not for mine. After this hurricane I’ll take out the glovebox and inspect that flap and possibly install a cover as you did, because when I want outdoor air I just roll the windows and sunroof down. My grandpa has an 02 and he said after riding in mine the flow in my 04 is not as good though the temperature at the vents is about the same there’s not much pressure although it makes a ton of noise it’s almost laughable how hard it sounds like it working yet the air can’t reach the back seats
     

Share This Page







We Support Our Troops!