Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

AC HELPPPP 97 Explorer

Discussion in 'A/C & Heater systems - HVAC' started by vlm2, July 21, 2006.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. vlm2

    vlm2 New Member

    Joined:
    June 15, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Marshall Mo
    Year, Model & Trim Level:
    1997 Explorer Sport
    The AC quit blowing cold last year, so we just used the windows untill this years. Our mechanic added some freon and run dye through the lines and couldn't find a leak. He said the stuff had a sealer in it also so if it did have a leak it should check it. SO anyway the air worked great for a while, now it still blows semi cool air but no where near cold.I had it check and it is still full.The air temp it blows is about 68 or 70 degrees.
    PLEASE TELL ME WHAT TO DO Temps here are at 100 degrees with indexs of 110 .

    Thanks
    Vicky
    vlm2@socket.net :confused:
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Glacier991

    Glacier991 EF Tranny Guru Moderator Emeritus

    Joined:
    February 8, 2003
    Messages:
    9,835
    Likes Received:
    24
    Trophy Points:
    48
    City, State:
    Sacramento, CA 95827
    Year, Model & Trim Level:
    1992 XLT
    You had it checked and it still full ? Sounds to me like a small leak....resulting in a low charge state. Show said it was still "Full". This is not like checking tire pressures.It is full of variables. I', betting you are just in a low charge state. How frequently is the compressor clutch cycling ?
     
  4. vlm2

    vlm2 New Member

    Joined:
    June 15, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Marshall Mo
    Year, Model & Trim Level:
    1997 Explorer Sport
    It wouldn't take anymore freon. That is why I say it is still full.The man at the automotive store checked it and tried to put more in and it would take any more. I even paid 10.00 for some booster stuff that was to make it even colder but it only helped a weeeeeee bit.
    Tell me more please.
    Vicky ;)
     
  5. rookieshooter

    rookieshooter Moderator Emeritus

    Joined:
    March 13, 2005
    Messages:
    7,296
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Martinsburg WV
    Year, Model & Trim Level:
    84 BII "Li'l Samson"
    You need to take it to someone who has a set of gauges and knows how to use them. They need to take some readings on the high side and low side while it is running and not just dummping more refregeant in the system. Those reading can tell you alot on what's happening. Is there a difference between low and high pressure or are they equalized? Bad valves in the compressor? Too high or too low. And if you take the reading right after running and the engine is off it will always show to high. Bet you got a slow leak if it did work for awhile after charging and then slowly got worse.
     
  6. Homerexplorer

    Homerexplorer Active Member

    Joined:
    August 12, 2005
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Upstate NY
    Year, Model & Trim Level:
    99 XLT 4WD
    Is the clutch engaging? Is the compressor getting warm/hot?
     
  7. gensic11

    gensic11 Guest


    i agree with rookieshooter - i tried using the "cheapo" guages at autozone and it was telling me i couldn't fill anymore freon into the system.. but then i finally grabbed some balls and took my truck to midas and they told me i was 2lbs low and so they recharged and wallah i have cold air again. Check your Accumulator (it's the tube looking thing that you filled your freon into at the auto store).. there should be a "blanket" around the tube. if you pull that blanket back you will probably see a lot of rust. this may be the source of your problem.. look into getting the accumulator replaced if you think it looks pretty bad. i know it's about a 50-70$ piece and fairly easy replacement if you have the right tools. i will probably have to get mine replaced within the next year if my newly charged A/C stops working again..
     
  8. vlm2

    vlm2 New Member

    Joined:
    June 15, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Marshall Mo
    Year, Model & Trim Level:
    1997 Explorer Sport
    OK,I will make an appointment with Midas.I have no idea about the highs and lows or the Accumulator, but I will look for it.kEEP THE IDEAS COMING I AM STILL SWEATING.
    YOU GUYS ARE GREATTTTTTTT

    VICKY :D
     

Share This Page







We Support Our Troops!