Dismiss Notice



Register Today It's free! This box will disappear once registered!

AC not working

Discussion in 'A/C & Heater systems - HVAC' started by justanother1, July 18, 2011.

  • Searches ExplorerForum.com
    1. justanother1

      justanother1 Active Member

      Joined:
      April 7, 2004
      Messages:
      139
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Dover, PA
      Year, Model & Trim Level:
      96 XLT; 97 XLT
      My ac is not working on our 97. I added a can of r134a to have the relief valve blow the charge right after adding the can. This is the 2nd or 3rd time the relief valve has blown. I used the gauge on the can. Had suction pressure about 50psi at idle. Then the suction pressure climbed to 90 or so just before the pressure blew off. I would have thought the high pressure switch would have cut off (if there is one). Ex was not run prior to me adding the can on Saturday morning. Do I replace the relief valve, high pressure switch, orifice, and recharge? Do you suggest I take it to some to have it done professionally? I have a set off gauges but don't have a vacuum pump of my own. I may be able to borrow one from a guy at work.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!