Dismiss Notice



Register Today It's free! This box will disappear once registered!

AC problem...Warm Air!!

Discussion in 'A/C & Heater systems - HVAC' started by JTSi, July 19, 2011.

  • Searches ExplorerForum.com
    1. JTSi

      JTSi New Member

      Joined:
      September 8, 2010
      Messages:
      19
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Middletown,Ct
      Year, Model & Trim Level:
      98 Explorer Sport
      Ok so my AC worked pefect last summer, nice and cold. Now this year im getting nothing but warm air. also the compressor seems to be cycling alot...about every 25-30 sec. I bought a recharging kit and when i checked the pressue it was at about 105! Needless to say i didnt add anything. So pressure is very high and no cold air...any help? i looked thru a couple threads and couldnt find anything similar to my problem. :mad:

      98 Explorer sport
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!