Dismiss Notice



Register Today It's free! This box will disappear once registered!

  • Searches ExplorerForum.com
    1. myfoot

      myfoot Member

      Joined:
      June 20, 2011
      Messages:
      80
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Illinois quad cities
      Year, Model & Trim Level:
      2017 Platinum
      Haven't really had to many problems since I was upgraded to 2.8 but the one I always notice is with the navigation. I was showing my son how neat the map is as opposed to say my TOMTOM when twice in a row the map stayed still and the pointer drove off the screen.

      Now like some others here, he's a software developer and just chuckled saying that should never have gotten out working like that. I can usually go to some other screen and come back, but this time it took a 2nd attempt to make it work right.

      Not the biggest thing in the world but pretty annoying. Anyone else have this ? I hadn't read it yet if they have. Rob
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. snowbird

      snowbird Member

      Joined:
      July 13, 2011
      Messages:
      66
      Likes Received:
      0
      Trophy Points:
      6
      City, State:
      Minn. & Florida
      Year, Model & Trim Level:
      2014 Explorer XLT
      Our nav. named Veronica at times will have me driving? across the lake or sometimes going thru the woods for a mile or so! maybe she wanted to go for a swim???? I attribute it to the system not having enough satellites up here in the north woods.
       
    4. gdecamp

      gdecamp Active Member

      Joined:
      February 20, 2011
      Messages:
      612
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Long Island, NY
      Year, Model & Trim Level:
      11 X Limited AWD
      Running version 2.11 and yes, just saw it for the first time the other day. Had to change screens to get it to work which sucks and is probably a little dangerous when you are driving. :rolleyes:
       
    5. myfoot

      myfoot Member

      Joined:
      June 20, 2011
      Messages:
      80
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Illinois quad cities
      Year, Model & Trim Level:
      2017 Platinum
      Not much sense updating to 2.11 then if that doesn't fix it.
       
    6. vfral1

      vfral1 Active Member

      Joined:
      February 8, 2011
      Messages:
      261
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Cumming, GA
      Year, Model & Trim Level:
      '11 LTD Golden Bronze
      My nav usually just "freezes" in the same position even though I might be a mile or two from where it shows. This happens mostly in the "boot" period; the first 5 minutes of driving. Still sucks though, I agree it should never had made it to production like that.
       

    Share This Page







    We Support Our Troops!