Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Air Bag Light / Seat Belt Warning

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by SterlingGrayXLT, March 14, 2012.

^^Searches ExplorerForum.com^^





  1. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    My service air bag light is on, and it's not the first time. It pops up and stays on periodically, usually for a day or two at a time before disappearing. It'll be fine for a few weeks and then come back.

    My service department's response is that they must plug the car into the computer to see the error. They think that maybe it's some connection under the drivers seat that could come loose. Every time it's in for service, the light is conveniently not on. The times that the light is on, I try and get the car to them but their technicians are already gone for the day and I'm SOL.

    I'm out of luck and out of ideas. Can anyone help? Anyone else experiencing this? Outcomes? Fixes?

    I'm going on a 3K roadtrip in 2 days and am rather unhappy that I'm told that I should not be worried about the airbag randomly going off, just that the airbag may not deploy in an accident. Great news going on a long trip with a pregnant wife. Excellent news to hear! (extremely sarcastic)


    Side Note/Venting:

    The Explorer was being serviced for a routine oil change before a long trip, the "tin roof noise", the "squeaky brakes". I complained again about the airbag light, but it was not on when being serviced so I knew they wouldn't/couldn't do anything about it. Long story -> Short: I picked up the car Monday evening. Tuesday morning the airbag light was back on! Short story -> Long: I dropped the car off last Wednesday. I asked if they could only do the oil change, I'd pick up Thursday. If they could fix the other issues, I'd be there before they close on Saturday. Saturday when I went to pick up the Explorer, the car was not ready and the gentleman in the service department didn't know what the status was of the vehicle but that it wasn't ready to drive. Come Monday I find out that the Sync update caused all kinds of issues and that after nearly a week, I got my car back with just an oil change and new Sync update. Fail. I just needed to vent. Again. Apparently I didn't get all my frustration out with the dealership, the Ford customer service phone/e-mail representatives, and by blowing them up with negativity on twitter.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Bill #5 Explorer

    Bill #5 Explorer Well-Known Member

    Joined:
    February 9, 2011
    Messages:
    1,103
    Likes Received:
    5
    Trophy Points:
    48
    City, State:
    Chicago Area
    Year, Model & Trim Level:
    2016 Explorer XLT
    Next time, take a picture with your cell phone. Maybe this will be good enough for them.
     
  4. Chimmy76

    Chimmy76 Member

    Joined:
    March 25, 2011
    Messages:
    81
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Virginia Beach,VA
    Year, Model & Trim Level:
    2012 Tundra
    My dealer gave me a data recorder with a trigger so when the light comes on push the button to record the data then take the vehicle in.
     
  5. FordService

    FordService Official Ford Rep

    Joined:
    October 25, 2010
    Messages:
    5,281
    Likes Received:
    11
    Trophy Points:
    48
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    2014
    SterlingGrayXLT,

    I arranged for you to be called; please also see the PM I sent for more details.

    Cory
     
    • Like Like x 1
  6. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    3 Words: VEHICLE HEALTH REPORT

    If you have My Ford Touch, you can go in while the error light is on and do a vehicle health report. Your dealer has access to it via. syncmyride.com or you can print it out from syncmyride and hand it to the dealer. I had a similar problem where I was getting intermittent error codes that would clear and I did this and the dealer gave me no problems as the error codes on the vehicle health report should be all the information the dealer neeeds and serves as your evidence that the light was on.

    I'm not sure a simple photo would work as my guess is that the error codes are more specific and will tell the dealer the exact problem. Just taking a picture of the light proves the light was on, but doesn't give the dealer the error code information they need to diagnose and fix the problem. The Vehicle health report would (assuming you have MFT).
     
  7. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    Thanks for the help Cory, I'm awaiting Wendy's call. I have her on my speed dial as of late!

    jrmexplorer - I would LOVE to run a Vehicle Health Report, but it is not an option for me! The new myfordtouch update does not have it loaded on my system. A Ford Sync representative just told me that I'd need to go to the dealership to have it corrected. No buttons, no voice control.

    Do you think I can get a refund after 14K miles and 10 months? LOL Maybe a Ford Gift Card for the purchase price I paid.
     
  8. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    UPDATE:
    made free hour appear out of thin air, went to dealer to have the code read... supposed faults with the seat restraint? "parts" on order now, not sure what but apparently something not held in stock. confirmed light on means airbag will not deploy if in an accident. swell...

    sidenote: after 10 minutes of waiting to speak to someone in the write-up area beforehand, the garage door gets closed on the rear bumper of my Explorer- i'm cursed
     
  9. 1sttimeford

    1sttimeford New Member

    Joined:
    March 29, 2011
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    Atlanta, GA
    Year, Model & Trim Level:
    2011 Explorer Limited 301
    SterlingGrayXLT

    If you would be so kind, please post more details on what parts were replaced after the dealer completes the work. My airbag warning light has been staying illuminated for extended periods of time since Monday.
     
  10. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    Absolutely, as soon as I have some good news I'll post the result and what parts were used!
     
  11. FordService

    FordService Official Ford Rep

    Joined:
    October 25, 2010
    Messages:
    5,281
    Likes Received:
    11
    Trophy Points:
    48
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    2014
    You’re very welcome, SterlingGrayXLT. I have confidence this will be resolved for you.

    1sttimeford,

    I have your VIN from previous messages; for me to help, please drop me a line via PM with your contact info, approximate mileage, and dealer name/state.

    Cory
     
  12. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    That's weird that you cannot run a vehicle health report. Have you talked with the dealer about that?
     
  13. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    Part #'s

    Just had the Explorer in yesterday for service to the squeaky brakes, the tin roof noise, a missing vehicle health report on the MFT, and the mysterious on-again/off-again air bag light... As requested, the part number listed for the airbag fix was my driver's side seatbelt pretensioner #BB5Z-7861203-BA. It's only been 2 drives since getting it back and so far, so good. I'll update again in a few days to see if it really stays off.

    No luck yet on the missing vehicle health report. My dealership had update my MFT system a few weeks ago. One day with that airbag light was on I was going to run the health report to try and capture it, but I couldn't locate it. Even with the Ford Technology team on the phone, we couldn't locate where it was supposed to be. When I got my car back yesterday the dealership advised that the system said everything is correct and loaded properly. No vehicle health report and nothing found when trying over the voice sync too.
     
  14. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    i'd disregard the part number previously provided. the light has returned, one day after picking it up for the fix. thank you ford for the free dealership wifi right now to post this. working from the ford dealership while it is fixed (hopefully), maybe working from here a half day will give me a 1/2 day's pay by ford and part of a pension!
     
  15. MikeFreas

    MikeFreas Active Member

    Joined:
    June 23, 2011
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    VA Beach VA
    Year, Model & Trim Level:
    2012
    My light just came on today while driving. The truck is 8 months old. This shouldn't happen.

    The dealer is nice enough to get me a rental but it's a paid in the ass and takes time from my day to get the truck to them.
     
  16. VinceL

    VinceL Well-Known Member

    Joined:
    May 24, 2011
    Messages:
    2,303
    Likes Received:
    2
    Trophy Points:
    48
    City, State:
    Frisco, TX
    Year, Model & Trim Level:
    2013 Explorer Limited
    Ours came on once after honking the horn. I forgot to run a VHR, and instead turned off the car and restarted it and it has not lit up since, even with honking the horn a couple more times. So who knows...
     
  17. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    mine has finally been fixed (at least been good since last fix 3 weeks ago). have your service department wiggle the airbag connection under the seats. mine was driver side. if its loose they should replace. ford tech line had them grease the connection points to make a better connection. seems to be the fix. seems like "securing" the connections was their first trial fix in dec, which didn't last long for me. they also in the previous month replaced the seat belt pretensioners and on another visit some module? under the seat. my dealer spent alot of time on the phone with some ford tech line as they could never fid anything wrong aside from the code/lighy being on.

    GOOD LUCK
     
    • Like Like x 1
  18. srearoyl

    srearoyl New Member

    Joined:
    May 31, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    NOVA
    Year, Model & Trim Level:
    2011 Explorer XLT
    Air bag light

    I've had the same problem with the air bag light. The computer said it was the tensioner...it has been replaced twice now, no change. Ford had the dealership checking pinouts and connectivity, reseating connectors, and now replacing the air bag module. I've been waiting almost a week for that part, and it has been in the shop since May 14th:mad:. The dealership gave me a loaner, but this is getting ridiculous. They've spent a good deal of time on the phone with Ford also.

    I'm not sure if Ford is willing to do anything for it...I'm going to wonder how many rattles and noises I'm going to have after they are done with it. (It was also in for the Sync update, A-pillar rattle, engine fan issues, and A/C blowing hot).

    Cory (or any other Ford CSR) any ideas? I'm starting to doubt both the dealership & Ford in general. I've never had an issue with any other Ford, but the new Explorer is giving me some serious doubts...after all, I haven't even had it a year!

    If anyone has any suggestion on what Ford should do, I'd be happy to hear them.

    Thanks!
     
    Last edited: May 31, 2012
  19. SterlingGrayXLT

    SterlingGrayXLT New Member

    Joined:
    May 24, 2011
    Messages:
    32
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Saint Joseph, MI
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    as my previous post said, I had the pretensioner replaced and the module. neither worked. replacing/securing the connection point and adding connection grease has seemed to do the trick, it's been 5+ weeks an I havent seen the light back... I think that making sure the connection is good seemed to be the trick. I'd ask your dealer to add the electrical connection grease and hope you get the result that I've seen these past few weeks.
     
  20. srearoyl

    srearoyl New Member

    Joined:
    May 31, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    NOVA
    Year, Model & Trim Level:
    2011 Explorer XLT
    I forgot to mention...dielectric grease was used either after the first pretensioner didn't work or after the second didn't work. When it was used, light went off for less than five minutes, and has been on ever since (still at dealer). Last I heard they had the center console out working on the problem.
     
  21. FordService

    FordService Official Ford Rep

    Joined:
    October 25, 2010
    Messages:
    5,281
    Likes Received:
    11
    Trophy Points:
    48
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    2014
    MikeFreas,

    I have your contact details from before; if you need to, I’m happy to arrange a follow-up for you.

    Have you told your dealer about that happening, VinceL? Please shoot me a PM if you see it again.

    I’m glad to read this was taken care of, SterlingGrayXLT.

    srearoyl,

    I want to have this concern reviewed by the Customer Service Manager for your region. Please send me a PM with your contact information, approximate mileage, dealer name/state, and VIN.

    Cory
     

Share This Page







We Support Our Troops!