Dismiss Notice



Register Today It's free! This box will disappear once registered!

Another cooling system question.

Discussion in 'Aerostar Forum' started by Raybz, July 25, 2011.

  • Searches ExplorerForum.com
    1. Raybz

      Raybz New Member

      Joined:
      March 7, 2011
      Messages:
      14
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Hometown, Illinois
      Year, Model & Trim Level:
      95 Aerostar xlt
      95 with the 3.0

      When the vent is on or norm air I'm getting a strong antifreeze smell in the van. With vent off or on Max Air there is no smell! Am I looking at a Heater Core? BTW Stopleak made no difference

      Not leaking anywhere that I can find, level stays good, just the smell
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,815
      Likes Received:
      296
      Trophy Points:
      113
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
      Check the cooling system with a cooling system pressure tester tool.
       

    Share This Page







    We Support Our Troops!