1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Battery drain? Could this be the problem. I've searched all morning!

Discussion in 'Stock 1995 - 2001 Explorers' started by power4glory, June 30, 2011.

^^Searches ExplorerForum.com^^





  1. power4glory

    power4glory New Member

    Joined:
    March 28, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    98
    I have a 98 explorer 4.0 sohc

    Every morning this week I have had to boost my vehicle. Just once to get it going. I cleaned all my connections, then replaced the battery thinking it wouldn't hold a charge, but neither has seemed to help.

    My brake light on my instrument cluster comes on and stays on the second I remove my key from the ignition. I am 100% sure this hadn't happened before. I spent all morning searching about this and found nothing. Is there somewhere I can start looking before I open my 40$ multimeter and do the checks for a parasitic drain? Will that light effectively drain the battery in 10 hrs? Any help at all would be hugely appreciated. Thanks!
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.








We Support Our Troops!