Dismiss Notice



Register Today It's free! This box will disappear once registered!

Battery draining issues

Discussion in 'Stock 2006 -2010 Explorers' started by praveen, July 1, 2011.

^^Searches ExplorerForum.com^^
  1. praveen

    praveen New Member

    Joined:
    March 17, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Qatar, Qatar
    Year, Model & Trim Level:
    2006
    I bought a new battery for my 2006 explorer in the month of November 2010. My vehicle was idle for almost a month and when I returned from vacation the battery had drained. As the battery was having warranty, I got the battery replaced with a new one. The new battery worked for almost 6 months and again drained. My explorer does'nt start.


    Are there any issues with battery or charging in 2006 explorers?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.

  3. aaronajb1981

    aaronajb1981 Active Member

    Joined:
    April 27, 2006
    Messages:
    522
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Minneapolis, MN
    Year, Model & Trim Level:
    '06 XLS
    Do you have any aftermarket alarm or remote start? If so there is a certain way to hook up the door locks for this not to happen.
     
  4. Explorer_PL

    Explorer_PL Elite Explorer

    Joined:
    November 16, 2007
    Messages:
    2,483
    Likes Received:
    115
    Trophy Points:
    83
    City, State:
    Rockland County, NY
    Year, Model & Trim Level:
    06EB V8 & 07EB V6
    I have same problem with my 06. I am on my 4th battery, and I have remote starter with alarm (all aftermarket) and I think that's my problem. The last battery lasted 9 months, luckily AutoZone gave me a new one.
     
  5. aaronajb1981

    aaronajb1981 Active Member

    Joined:
    April 27, 2006
    Messages:
    522
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Minneapolis, MN
    Year, Model & Trim Level:
    '06 XLS
    There are known issues with after market alarms/starters and the keyless portions of them. If you dont diode the lock/ unlock wires this problem will happen.

    Even the tech notes for aftermarket installs (remote starts and alarms) calls out for the diodes or it can cause the battery drain.
     
  6. praveen

    praveen New Member

    Joined:
    March 17, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Qatar, Qatar
    Year, Model & Trim Level:
    2006
    I suspect the rating of the battery AC DELCO NX110-5LF that was replaced earlier. Now I have replaced with AC DELCO 65-72S which is recommended for Explorer. The only additional modification done by me was addding a rear radar sensor.

    I will have to wait and see how long this battery would last!!!!
     
  7. aaronajb1981

    aaronajb1981 Active Member

    Joined:
    April 27, 2006
    Messages:
    522
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Minneapolis, MN
    Year, Model & Trim Level:
    '06 XLS
    I would have your alarm checked and fixed by the shop that installed it to make sure its installed properly and that the lock wires are infact diode isolated. If they are not its just a matter of time.
     






We Support Our Troops!