Dismiss Notice



Register Today It's free! This box will disappear once registered!

Blown fuses after installing radio

Discussion in 'New Member Introductions' started by Hal Hjelm, January 2, 2018.

  • Searches ExplorerForum.com
    1. Hal Hjelm

      Hal Hjelm New Member

      Joined:
      January 2, 2018
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Rexburg idaho
      Year, Model & Trim Level:
      2002 mazda b3000
      Hi everyone got a problem I put a new radio in my sons 2002 mazda b3000 noe it keeps blowing fuses for the centrality security module and no tail lights or dash lights I have checked all wires by radio and have found nothing
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Rick

      Rick Pumpkin Pilot Staff Member Admin Elite Explorer

      Joined:
      February 8, 1999
      Messages:
      30,850
      Media:
      40
      Albums:
      4
      Likes Received:
      486
      Trophy Points:
      113
      City, State:
      Wayoutin, Aridzona
      Year, Model & Trim Level:
      '93 XL Pumpkin Edition
      Callsign:
      AB7FH
      My guess is that you tapped into one of the wrong wires when you changed radios placing a ground on a positive circuit, or something of that nature.
       

    Share This Page







    We Support Our Troops!