Dismiss Notice



Register Today It's free! This box will disappear once registered!

Brand NEW MFT craziness and right before vacation

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by dismania, July 13, 2011.

  • Searches ExplorerForum.com
    1. dismania

      dismania New Member

      Joined:
      February 14, 2011
      Messages:
      20
      Likes Received:
      0
      Trophy Points:
      0
      So, I have had lots of problems with H.A.L. (oops, I mean MyFord Touch), but I have been able to live with most of them. However, the most recent one has me scratching my head. I am 1 day away from leaving on a 3,000 mile+ trip for 3 weeks. All of a sudden the MFT system has decided to switch stations on my radio every 30 seconds or so. It is almost as if it is doing a scan of the channels. I do not have to have the MFT system on the entertainment screen for it to happen. I has changed stations on all inputs (AM, FM and Sirius), as well as switched inputs on me.

      Even after turning the radio off, you could still here the "ding" from the system as if it was hitting a button.

      We have had a heat wave here in town and temps were above 95 degrees. Maybe it was all heat related as today, it seemed to be behaving, (knock on wood), but this problem is just baffling to me.

      I tried a master reset as well as pulling the fuse and disconnecting the battery. None of them seemed to have an immediate effect.


      I'll keep everyone updated, but has anyone else experienced this issue?


      Dismania
       
      Last edited: July 13, 2011
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. jrmexplorer

      jrmexplorer Well-Known Member

      Joined:
      April 19, 2011
      Messages:
      1,109
      Likes Received:
      1
      Trophy Points:
      0
      Year, Model & Trim Level:
      2011 Limited
      Sounds like a stuck button maybe? Try pushing all the buttons, both on the steering wheel and the console stack to see if you can pop it out.
       
    4. BethesdaEC

      BethesdaEC Active Member

      Joined:
      June 1, 2011
      Messages:
      122
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Ellicott City, MD
      Year, Model & Trim Level:
      2011 Red Explorer Limited
      Isn't there an auto scan button on the screen. If it's lit up, turn it off.
       
      Last edited: July 13, 2011
    5. RandyH2

      RandyH2 Active Member

      Joined:
      March 28, 2011
      Messages:
      822
      Likes Received:
      17
      Trophy Points:
      18
      City, State:
      MI
      Year, Model & Trim Level:
      '11 Limited AWD
      Yikes- the second potential heat-related button issue.....
       
    6. VinceL

      VinceL Well-Known Member

      Joined:
      May 24, 2011
      Messages:
      2,303
      Likes Received:
      2
      Trophy Points:
      48
      City, State:
      Frisco, TX
      Year, Model & Trim Level:
      2013 Explorer Limited
      That was my thought exactly! :(
       

    Share This Page







    We Support Our Troops!