Dismiss Notice



Register Today It's free! This box will disappear once registered!

Break lights flash instead of blinkers

Discussion in 'Stock 1991 - 1994 Explorers' started by johnnyboxturtle, August 13, 2017.

^^Searches ExplorerForum.com^^
  1. johnnyboxturtle

    johnnyboxturtle New Member

    Joined:
    August 13, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Portland, oregon
    Year, Model & Trim Level:
    1992 explorer xl
    I recently received a 92 explorer xl from a friend. The blinkers were not working in any way. I replaced the buss flasher and now they work, sorta, the breaklights flash and the blinkers do nothing. I'm not sure what to do next.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. natenkiki2004

    natenkiki2004 Blue Bomb!

    Joined:
    November 3, 2013
    Messages:
    2,043
    Likes Received:
    64
    Trophy Points:
    68
    Location:
    North Idaho
    Year, Model & Trim Level:
    1991 & 1994 Explorers
    On the 1991-1994 Explorers, the brake light is the turn signal. There's only 3 elements on each side: 1 for backup, 1 for marker lights and 1 for brake/turn. Sounds normal to me. Or perhaps you mean that the rear turn signals work but the fronts don't?
     
  4. boominXplorer

    boominXplorer Elite Ranger Elite Explorer

    Joined:
    September 16, 2002
    Messages:
    8,775
    Media:
    55
    Albums:
    3
    Likes Received:
    464
    Trophy Points:
    103
    City, State:
    Virginia Beach, Va
    Year, Model & Trim Level:
    00 4x4 Mounty
    Check the rear bulbs and make sure the the contacts arnt covered in corrosion. The bulb can blow and cross contacts internally and cause the your issue.
     






We Support Our Troops!