Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Cannot update MFT 2.11

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by magicaltrevor70, October 29, 2016.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. magicaltrevor70

    magicaltrevor70 New Member

    Joined:
    September 15, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2012 Explorer Limited
    Same thing. I also tried on a different browser, and was prompted to sign in but then got the same error.
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,638
    Likes Received:
    1,276
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve II
    Callsign:
    VE3
    I get the same error message.

    Peter
     
  4. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,638
    Likes Received:
    1,276
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve II
    Callsign:
    VE3
    Have you tried clicking on the Sync and Vehicle Features tab after you got the error and then looking at the options presented? I was able to do that despite getting the error msg.

    Pete
     
  5. magicaltrevor70

    magicaltrevor70 New Member

    Joined:
    September 15, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2012 Explorer Limited
    Yes, I can get there but there isn't an option for Sync version checker
     
  6. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,638
    Likes Received:
    1,276
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve II
    Callsign:
    VE3
    Hi Shaay. Here is a link that Rebecca provided to me when I had the same issue trying to report 3.8.. I believe it put some sort of retrieval file on the USB stick that when plugged into the vehicle pulled the existing version from it so that it could be reported to update my account. Unfortunately the lick no longer seems to work. Just thought there might be something else along that line now. https://owner.ford.com/tools/accoun...oftware-version.html?step=prepare-sa#/prepare

    Peter
     
  7. magicaltrevor70

    magicaltrevor70 New Member

    Joined:
    September 15, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2012 Explorer Limited
    I tried using a US VPN and I still get the same error. Shaay, any thoughts?
     
  8. FordIVTteam

    FordIVTteam Official Ford Rep

    Joined:
    July 13, 2011
    Messages:
    1,690
    Likes Received:
    1
    Trophy Points:
    58
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    Ford Explorer
    Hey Peter,

    The link that Shaay provided is updated from the one Rebecca posted.

    magicaltravor70,

    If you're still receiving an error, you may need to go back to the dealer and have them confirm.

    Cara
     

Share This Page







We Support Our Troops!