Dismiss Notice



Register Today It's free! This box will disappear once registered!

Charging system problems and alternator fuse?

Discussion in 'Stock 2002 - 2005 Explorers' started by Eblood613, August 6, 2011.

  • Searches ExplorerForum.com
    1. Eblood613

      Eblood613 New Member

      Joined:
      August 6, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      2003 Explorer v6 SOHC FLX
      Lately my charging system has been acting up and I'm unsure why. The battery is a day old and the alternator is about 3 months old. The alternator seems to charge but not as well as it should. I'm going to try changing the battery terminals and check all the wires but Im'm curious as to if it could be a fuse. And I'm unsure which fuse is used by the alternator. Any:rangertan: help is greatly appreciated. Thanks
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!