Dismiss Notice



Register Today It's free! This box will disappear once registered!

cracked radiator???

Discussion in 'Under the Hood' started by posmindset, June 19, 2011.

  • Searches ExplorerForum.com
    1. posmindset

      posmindset Member

      Joined:
      May 26, 2009
      Messages:
      98
      Likes Received:
      0
      Trophy Points:
      6
      Year, Model & Trim Level:
      02, Explorer 4.6L 4x4
      how can i turn off the check engine light?

      last night i had a problem with my 02 explorer (eddie bauer 4.6 liter).

      I was driving on the interstate for about 15 minutes and then exited off to a city street with alot of stop and go traffic. After sitting at a stoplight i started to drive forward when it turned green and the engine suddenly shut down.

      I felt like i was running on one cylinder. It was still running but just enough to move the car to a side street. the gauges told methe engine temp was pegged sky high and the check engine light came on.

      I popped the hood and could see that the compartment for radiator fluid was empty. I was able to get water and add stop leak and after a 1.5 hour wait i started it and temp gauge is running normal and the power is back in the engine.

      It seems to be holding fluid now...maybe the stopleak is working.

      check engine light is still on though, how can i get that to turn off or reset?

      also...is that a safety device that shut the engine down to about 10% performance? curious

      thanks
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Joe Dirt

      Joe Dirt Explorer Addict

      Joined:
      October 4, 2007
      Messages:
      13,410
      Likes Received:
      9
      Trophy Points:
      0
      Year, Model & Trim Level:
      07 Camry
      I would probably try to figure out where all of your coolant went, what the codes are that are throwing the CEL, and fix the problem rather than just turn off the light and run stop leak... Just my .02 :)
       
    4. posmindset

      posmindset Member

      Joined:
      May 26, 2009
      Messages:
      98
      Likes Received:
      0
      Trophy Points:
      6
      Year, Model & Trim Level:
      02, Explorer 4.6L 4x4
      As i had mentioned in my first post, i had already added the stopleak and it's working. So I'm not able to see where the coolant went, if there was a leak in the radiator or any hoses.

      I'm running it up to autozone after work to get the codes.
       

    Share This Page







    We Support Our Troops!