1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

???? Dash instruments go goofy when A/C is on.

Discussion in 'Stock 1991 - 1994 Explorers' started by gmanpaint, August 3, 2011.

^^Searches ExplorerForum.com^^





  1. gmanpaint

    gmanpaint It's Always Something! Staff Member Moderator Elite Explorer

    Joined:
    August 1, 2008
    Messages:
    10,128
    Likes Received:
    873
    Trophy Points:
    143
    City, State:
    MO MO
    Year, Model & Trim Level:
    Modified 95 XLT
    Weirdest thing. When the A/C is on, 3 of 4 gauges act up.

    Switch A/C on..
    Oil pressure gauge goes up.
    Temp gauge goes up.
    Volt gauge goes up.

    Turn the fan from low to high, all three go even higher. Start from low fan speed, and go up one speed at a time, they all go up following the fan speed selection.

    Turn the fan speed from high to low, all three go down following the fan speed selection.

    So, the higher the fan speed is, the higher the gauges read. The lower the fan speed is, the lower the gauges read. The needles move instantly up or down with the fan speed switch.

    Is my Cluster messed up? Is there something else that would cause this?

    Thanks in advance for any ideas here. :salute:
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. ragajungle

    ragajungle Well-Known Member

    Joined:
    November 8, 2008
    Messages:
    1,036
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago, IL
    Year, Model & Trim Level:
    89 BroncoII & 05 Taurus
    In my 94 i had a problem with the negative ground cable or one of its many acc leads... had coroded.. if I ran too many acc's or if the abs was activated the dash would go crazy. it eventually got so bad the car would clunk out in the middle of traffic and have no power to anything. I would say check to make sure the neg cable and terminal are in good repair - not rusty, loose, corroded, etc...
     
  4. gmanpaint

    gmanpaint It's Always Something! Staff Member Moderator Elite Explorer

    Joined:
    August 1, 2008
    Messages:
    10,128
    Likes Received:
    873
    Trophy Points:
    143
    City, State:
    MO MO
    Year, Model & Trim Level:
    Modified 95 XLT
    Hmmm...I have new cables on it and a new battery. Wonder if the ground is loose? I will check it out in the am. Thanks!
     
  5. Mudboy

    Mudboy Active Member

    Joined:
    July 22, 2010
    Messages:
    244
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Bellmawr NJ
    Year, Model & Trim Level:
    91 ex
    not sure on these but be sure your motor to frame ground is good and body ground is good as well. amazing what them little things can cause.
     

Share This Page







We Support Our Troops!