Dismiss Notice



Register Today It's free! This box will disappear once registered!

defrost only vacuum help plz?

Discussion in 'Stock 1995 - 2001 Explorers' started by jwyow865, July 17, 2011.

  • Searches ExplorerForum.com
    1. jwyow865

      jwyow865 New Member

      Joined:
      July 12, 2011
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      knoxville, tennessee
      Year, Model & Trim Level:
      '96 xlt
      ok so a/c would not work on high speed so took everything apart checked resistor and switch and bla bla bla but anyway it was the high speed relay so pulled the air box (more like cylinder) out and replaced the relay 11$ fix

      yay the high speed works awesome not! the air only comes out of the defrost i see the bomb looking vacuum thingy and checked for leaks not hissing or visible signs of leak?

      what is the best way to test for a vacuum leak i think i broke or cracked a hose but do not know where?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    Share This Page







    We Support Our Troops!