Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Defrosters

Discussion in 'Stock 2006 -2010 Explorers' started by Mickalo, December 31, 2017.

^^Searches ExplorerForum.com^^





  1. Mickalo

    Mickalo Active Member

    Joined:
    February 28, 2017
    Messages:
    134
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    NW., Iowa
    City, State:
    Iowa
    Year, Model & Trim Level:
    2010 Explorer w/4.0 4wd
    since we've been a deep freeze here last few days notice my defrosters isn't working properly on the driver's side but works great on the pass. side. The heater & blower works good when switching from defrost to dash panel it blows out plenty of heat just notice the it's barely defrosting on the driver side. what would causing this? I did check to make sure nothing was restricting the defroster duct on the driver side to it's all clear.

    TIA
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



Share This Page







We Support Our Troops!