Dismiss Notice



Register Today It's free! This box will disappear once registered!

Drivers side speaker

Discussion in 'Explorer Audio & Navigation' started by Michowski, May 25, 2018.

  • Searches ExplorerForum.com
    1. Michowski

      Michowski New Member

      Joined:
      December 23, 2012
      Messages:
      40
      Likes Received:
      1
      Trophy Points:
      18
      Year, Model & Trim Level:
      2002 explorer xls
      The speaker on my drivers side right now cut's in and out. Sometimes when it cuts out, I turn just flick the volume up and it comes back on. Other times it is completely off. Sometimes it will stay on and play ok. I just in the past 20 minutes put Type R replacements all around. Checked all the connections, did not see anything wrong. No cut wires or anything. Anybody else ever have this happen? It used to be fine and never had an issue and then all the sudden it did.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Michowski

      Michowski New Member

      Joined:
      December 23, 2012
      Messages:
      40
      Likes Received:
      1
      Trophy Points:
      18
      Year, Model & Trim Level:
      2002 explorer xls
      It's gotta be a wire in the harness. I had the entire door pulled apart and was holding the speaker plugged in. Just wiggling the wires I could get it to cut in and out. I initially thought it was in the plug, bought an adapter so I wouldn't have to cut any wires. I cut it and soldered the wires directly but it still does it. Looks like the entire wire needs to be replaced to fix it properly
       
    4. 94xlt4x4

      94xlt4x4 Active Member

      Joined:
      January 30, 2006
      Messages:
      328
      Likes Received:
      1
      Trophy Points:
      18
      Location:
      Southeast PA
      Year, Model & Trim Level:
      2012 Limited 4x4 3.5L
      I had the same issue in my 04 before I traded it. I ended up running new wiring to the driver's door from under the dash to fix it. There was no continuity between the OE plug in the door and the OE plug in the dash, and no obvious place I was able to find where the wire was broken.
       
    5. Mbrooks420

      Mbrooks420 High Voltage. Elite Explorer

      Joined:
      February 2, 2002
      Messages:
      7,282
      Media:
      4
      Albums:
      1
      Likes Received:
      439
      Trophy Points:
      103
      City, State:
      Erie, Pennsylvania
      Year, Model & Trim Level:
      1998 Mountaineer AWD
      I’d suspect the door hinge first.
       

    Share This Page







    We Support Our Troops!