Dismiss Notice



Register Today It's free! This box will disappear once registered!

Flashing 4WD high and low lights.

Discussion in 'Transmissions & Transfer Cases' started by Biguy984, July 14, 2011.

  • Searches ExplorerForum.com
    1. Biguy984

      Biguy984 New Member

      Joined:
      July 14, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      98 Mercury Mountaineer
      Hi I have a 98 Mercury Mountaineer. 192,000 miles. Had transmission work done. The truck was riding good. when flashing 4wd High and Low came on. It flashes about 6times. And my Engine Light stay's on. Plus my wheels want turn,keep hearing clinking noise. :( I took it back to the transmission people, and they told me that the transfer case went bad. OK!! so i got a second opinion, So I go to Dealership, they charged me $100 to put it on the diagnostic machine. and said my 4wd had locked up. and i needed to replace a module,sensors, And a speed sensor. And it would cost me 1,000 for repair's. :mad: Can anyone help me out, So i can do the repair's and save money PLZ!!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,837
      Likes Received:
      298
      Trophy Points:
      113
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
      Welcome to this forum! I've moved your thread into the transmissions & transfer cases section. What were the code numbers from the diagnostic?
       
    4. Blewyn

      Blewyn New Member

      Joined:
      October 22, 2006
      Messages:
      27
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Muscat, Oman
      Year, Model & Trim Level:
      1997 XLT
      I'm having exactly the same problem with my 97 Explorer. 4x4 lights flash intermittently about 6 times at random times. Also getting the 'clunk' on corners as the 4x4 transfer case pops out of gear because I'm in 4x4 on dry road (switch in auto).

      One thing I noticed was this - the car would only enter 4x4 and do the 'strain then clunk' thing after the car had been turned off then restarted. It happened to me a few times at the petrol station, for example. When I took it to the Ford garage, he immediately gave me the story about the TC clutches (black oil there, apparently) and also pointed out that we have non-identical tyres (same size of course but different brand/tread).

      So what do you think ? If the tyres or TC gears were the problem, wouldn't the car be torquing up on all corners, not just after being switched off ? If I drive the car in a straight line after restart it seems to slip back into 2WD.....so it seems to me like a switching issue not a mechanical one. Shouldn't the car start in 2WD ?

      My garage is also talking about replacing the TC etc.....but I suspect all it really needs is an electrical fix. Can anyone shine a light on this please ?
       

    Share This Page







    We Support Our Troops!