1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Ford Explorer Surging on Start

Discussion in 'Stock 2002 - 2005 Explorers' started by Rotech1, June 15, 2011.

^^Searches ExplorerForum.com^^





  1. Rotech1

    Rotech1 New Member

    Joined:
    June 15, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Nassau
    Year, Model & Trim Level:
    2005 XLT
    Hello everyone forgive me if I posted incorrectly. My Ford Explorer 2005 XLT always surges on cold and warm start, changed coil pack, plugs, wires, serviced lubes etc even replaced with new throttle body, just reached 60,000 miles, experiencing rough idle. Been at this over and over for three months. checked vacuum leak nothing, only thing left to change if entire Jeep.. any ideas please.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. mobeious

    mobeious Member

    Joined:
    September 3, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    florida
    Year, Model & Trim Level:
    2004 Explorer XLT V8
    i had the rough idle.. it was the fuel filter .... the surging might have something to do with the transmission .. they are POS
     

Share This Page







We Support Our Troops!