Dismiss Notice



Register Today It's free! This box will disappear once registered!

front pass hub smoking

Discussion in 'Stock 1991 - 1994 Explorers' started by rustyboltz, June 27, 2011.

  • Searches ExplorerForum.com
    1. rustyboltz

      rustyboltz New Member

      Joined:
      April 26, 2010
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Paola, KS
      Year, Model & Trim Level:
      1993 X Sport 2001 Mount
      Today i took my 93 X out for a cruise after doing some work on the fuel level sending unit and fuel pump. When I was on the way home after approx. 25 miles, the truck acted like the brakes were grabbing on the right side. When I got home, The right side of my front axle was just covered with whiteish colored smoke. The hub (that has the 4X4 on it) was so hot that I could not touch it. Any way, I let it cool for about half hour and jacked the truck up and took off the tire off and the brakes were ok and the rotor was able to be turned. Does this mean that my 4 wheel unit in the axle is in need of being rebuilt? What went wrong that would cause it to overheat?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. parli22

      parli22 Loco en cabeza

      Joined:
      August 5, 2001
      Messages:
      659
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New York
      Year, Model & Trim Level:
      92 Explorer UNEDDIE
      well from what you just said it looks like the front auto hubs have bite the dust. You should really upgrade them to manuel hubs anyway. Your front differential and transfer case are still an unknown.but it sounds like the auto hub engaged which caused your truck to feel like it braking, even when on the gas.
       

    Share This Page







    We Support Our Troops!