1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Fuel Injector Nightmare

Discussion in 'General Explorations!!' started by monkeydude3, December 12, 2004.

  • Searches ExplorerForum.com
    1. monkeydude3

      monkeydude3 Active Member

      Joined:
      May 8, 2004
      Messages:
      477
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Millbrook, Illinois
      Year, Model & Trim Level:
      2001 Explorer Sport Trac
      Hey all~
      I have quite a pickle... I have a 1994 XL with a 4.0L V6.... I just ordered six remanufactured fuel injectors and installed them perfectly... and guess what, this biotch runs worse.... It idles like garbage and sounds like it has a high end cam in it.... and when i hit the gas the whole engine shakes like mad.... I checked the spark plugs, no oil or anything... so my block is fine.... I get to pull the injectors out and request another set from the company.... This is rediculous.... I was wondering if anyone knows any method of testing the injectors one by one.... or should I Just let this company take care of it.... also, any tips for doing injectors... I did it all down to the book... this sucks because I cannot drive it under these conditions and I'm afraid it will eventually not run all together... thanks

      george
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. hermitrl

      hermitrl Active Member

      Joined:
      December 11, 2003
      Messages:
      203
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      sturgeon falls ont canada
      Year, Model & Trim Level:
      92 4dr EB
      Well---if your 94 is like my 92---check the vacuum hoses on the tree thingy on the intake manifol. It is just an attachment point for all of the vacuum hoses. Mine had one that fell off of the back and couldn't be seen. It made the engine sputter badly. You could hear the hissing of the leak. I thought it was the IAC--and it could be the culprit too. It is fairly easy to remove and clean. There is a thread here with pics on how to do it.
      From your description--it sounds like a vacuum leak though--so check the hoses out.
       

    Share This Page







    We Support Our Troops!