Dismiss Notice



Register Today It's free! This box will disappear once registered!

Fuel pump issues.

Discussion in 'Stock 2002 - 2005 Explorers' started by n452mk, July 5, 2011.

^^Searches ExplorerForum.com^^
  1. n452mk

    n452mk New Member

    Joined:
    July 3, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    KISSIMMEE, FL
    Year, Model & Trim Level:
    2002 and 2001 EXPLORERS
    Hi guys my Ford Explorer 2002 XLT is the 2nd time that burns the 15A fuse of the fuel pump according to the manual, any help or tips i can do to solve this, im using premium 93 fuel now and i check and the fuel pump here in Orlando Florida is around 250 to 400 dollars, any help please ???

    Thanks im frustrated, just waiting for the new fuse to burn again :(
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.

  3. BrooklynBay

    BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

    Joined:
    November 11, 2005
    Messages:
    53,027
    Likes Received:
    321
    Trophy Points:
    113
    City, State:
    Brooklyn, NY
    Year, Model & Trim Level:
    88 89 93 95 96 Aerostars
    Welcome to this forum! I've moved your thread into the stock 2002-2005 section. Your post says that you have a 2002, but your profile says that you have a 2001. :confused:
     






We Support Our Troops!