1. Register Today It's free! This box and some ads will disappear once registered!

    Dismiss Notice

Fuel Pump Problems

Discussion in '2001-2005 Explorer Sport Trac' started by dallasb53, November 29, 2011.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information


  1. dallasb53

    dallasb53 New Member

    Joined:
    November 29, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    the other day my 2004 Sport Trac died while i was driving down the road.
    i towed it to the house, and determined the fuel pump was bad by:
    1) listening to the tank (no buzzing when key is turned to run)
    2) checked the fuel pump fuse, still good
    3) checked the relay connections for power, got 1 always hot... 1 hot with key in run position
    4)checked for power on the female connection and got battery voltage on 2 wires y/wh and gr/pk
    5)replaced fuel pump and filter and still no buzzing when key is turned in run position
    6)replaced new fuel pump with a newer fuel pump... to no avail

    i guess my two questions are 1)what else should i check and 2) what are the y/wh and gr/pk wires for? haynes doesnt have a wiring diagram for it(go figure right)

    ... any help would be appreciated!
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. ncranchero

    ncranchero Co-moderator Staff Member Moderator Elite Explorer

    Joined:
    August 14, 2004
    Messages:
    3,737
    Likes Received:
    8
    Trophy Points:
    48
    City, State:
    Denver,NC
    Year, Model & Trim Level:
    '94 F150 4x4 SWB 4.9L
    Possibly/probably the fuel pump driver module. You checked the inertia switch under the dash, right? I sent you some diagnostics and wiring connector pin-outs.Check your gmail.
     
  4. jasonmac

    jasonmac New Member

    Joined:
    November 30, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Manteca, CA
    Year, Model & Trim Level:
    01 Expr Sport Trac 4X4
    did it work?

    I have had similar problems but havent replaced the pump yet. looking to diagnose fully before purchacing one. maybe I can get the diagnostics / diagrams from you as well
     
  5. ncranchero

    ncranchero Co-moderator Staff Member Moderator Elite Explorer

    Joined:
    August 14, 2004
    Messages:
    3,737
    Likes Received:
    8
    Trophy Points:
    48
    City, State:
    Denver,NC
    Year, Model & Trim Level:
    '94 F150 4x4 SWB 4.9L
    Sure Jason, just sent it.
     
  6. JohnnyO

    JohnnyO Moderator Emeritus

    Joined:
    January 4, 2005
    Messages:
    1,833
    Likes Received:
    4
    Trophy Points:
    48
    City, State:
    Pittsburgh, PA
    Year, Model & Trim Level:
    '08 Sport Trac
    I think it's the inertia switch. When my son accidentally kicked mine (on my old '05 Trac) with his size 13's I had to hit and/or hold the reset button a bunch of times before it finally started. Later I got a check engine light, although it still ran, took it to the dealer and it was the inertia switch.
     

Share This Page







We Support Our Troops!