Dismiss Notice



Register Today It's free! This box will disappear once registered!

Fuel reservoir

Discussion in 'Bronco II' started by Deuling, July 14, 2011.

  • Searches ExplorerForum.com
    1. Deuling

      Deuling Member

      Joined:
      October 2, 2009
      Messages:
      78
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Muskegon Michigan
      Year, Model & Trim Level:
      1986 Ford Bronco2 4x4 xlt
      On the frame under the driver side door on my 86 theirs this reservior that has a filter in the bottom and the feed and return fuel lines and some check valves. The 2.9 was runnin crappy and I switched the filter in their, ran good for a while, then crappy again. Took the filter off not clogged, looked up and one of the check valves was laying sideways. I rerouted the lines to bypass this and now it wont run. I connected the feed to the feed and return to the return. im confused. Any thoughts???
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    3. ncranchero

      ncranchero Co-moderator Staff Member Moderator Elite Explorer

      Joined:
      August 14, 2004
      Messages:
      3,737
      Likes Received:
      5
      Trophy Points:
      48
      City, State:
      Denver,NC
      Year, Model & Trim Level:
      '94 F150 4x4 SWB 4.9L
      Have you cycled the ign switch repeatedly before trying to crank it? Have you activated the fuel pump manually from the EEC-IV test connector under the hood? You mention the CHECK VALVE was out of place. Think those check valves are there for a purpose?
      Those reservoirs are on 80-86 F150/Bronco/Bronco II/Rangers. Only the '86 model has the filter in it though. Find one and put it back as designed.

      New ones can be had @ http://www.lmctruck.com/icatalog/fr/full.aspx?Page=100
       
    4. Deuling

      Deuling Member

      Joined:
      October 2, 2009
      Messages:
      78
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Muskegon Michigan
      Year, Model & Trim Level:
      1986 Ford Bronco2 4x4 xlt
      Ive cycled the ignition yes. i was told it could be bypassed. also this thing has almost every electronic part on it brand new you could think of. Spent way too much money on it and now it doesnt run lol. New fuel pumps. Im at a loss.
       
    5. janderson4010

      janderson4010 Moderator Emeritus

      Joined:
      August 15, 2009
      Messages:
      1,298
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      third boxcar, midnight train
      Year, Model & Trim Level:
      86 BII
      when you say it was running crappy what was it doing exactly? like hesitating, idling rough, stalling, what?
       

    Share This Page







    We Support Our Troops!