1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Fuse Question - '96 Sport

Discussion in 'New Member Introductions' started by markonomicon, December 17, 2004.

  • Searches ExplorerForum.com
    1. markonomicon

      markonomicon New Member

      Joined:
      December 17, 2004
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Eunice/Lafayette, Louisiana
      Year, Model & Trim Level:
      '96 Sport
      Here's the story....

      I changed the terminals and battery on my '96 Explorer Sport. While 'trying' to fiddle with the old terminals, I unhooked/hooked up the terminals quite a few times. Got everything taken care of. Started her up and my audio was shot. No juice to the amp or radio. I checked out the buss fuse and it was fine. I'm an audio idiot, so please bear with me. :smoke: In the 2 1/2 years I've owned the truck, I never had an owners manual....(and it seems every time I'm at the parts store they never have any in). Anyway, after the rant (sorry I'm exhausted)....my question is...'Which fuse locations should I check?' (...And any other advice!).............Any help is appreciated. Thanks in advance.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!