1. Register Today It's free! This box and some ads will disappear once registered!

    Dismiss Notice

Gauges... possessed they are, someone call Ghostbuster

Discussion in 'Stock 2002 - 2005 Explorers' started by CaptainObvious, August 15, 2005.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information


  1. CaptainObvious

    CaptainObvious Active Member

    Joined:
    June 22, 2005
    Messages:
    479
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Central, IL
    Year, Model & Trim Level:
    04 XLT
    So while sitting in the truck this PM listening to the radio, I noticed AFTER I shut the truck off, about 10 seconds later the gauges bottomed out, went all the way over to the redline they back to the "normal spot".
    WTF is this all about?
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. CaptainObvious

    CaptainObvious Active Member

    Joined:
    June 22, 2005
    Messages:
    479
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Central, IL
    Year, Model & Trim Level:
    04 XLT
    :navajo:
     
  4. trucku

    trucku Well-Known Member

    Joined:
    January 25, 2005
    Messages:
    2,028
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    Queens, New York and living in Budd Lake, NJ now.
    Year, Model & Trim Level:
    2002 Explorer XLS 4.0 4x4
    Thats wierd. The only time my truck ever cycled the gauge is when i had battery disconnected. I connected it and started truck to seem them all go redline then back.
     
  5. misconceived

    misconceived Active Member

    Joined:
    July 10, 2005
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    EAST of NOWHERE U.S.A.
    Year, Model & Trim Level:
    '04 XLT
    Hello all this is my first post, i have been reading and learning and i hit my first problems today. I have an 04 xlt and i had the same thing happen to me today. Only reason i noticed it is because i was trying to figure out what the hell was going on with my gas gauge, problem 2. Same thing happened after 10 or 15 seconds my gauges bottomed out and went back up. As far as my gas goes i was on the way to fill up and my gas light came on. After putting 65 dollars in my tank, damn, my gas gauge stayed on empty with my check gage light continuing to glow. Any ideas on why my gauge is stuck? after about 6 hours it has finally moved up to about half a tank . I always reset my trip when i fill up just incase something like this happened. I know i have a full tank but im still trying to figure out whats up. I was thinking an electrical short when i saw the other gauges move. any help?
     

Share This Page







We Support Our Troops!