Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

got some more trouble codes!

Discussion in 'Modified 2002 - 2005 Explorers' started by armysoldier30263, July 21, 2012.

^^Searches ExplorerForum.com^^





  1. armysoldier30263

    armysoldier30263 Active Member

    Joined:
    August 4, 2010
    Messages:
    692
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shaw AFB, SC
    Year, Model & Trim Level:
    05 BLACK 4.0 XLT
    well its that time again ... fixed an antifreeze leak and connected my code reader and got these:

    U1900 controller area network communication bus malfunction receive malfunction NON-MIL

    B1805 mismatched PCM and / or ABS-TC module NON-MIL

    C2900 vehicle identification number mismatch NON-MIL

    ive searched on other OBD II websites but haven't found anything anybody had these codes before?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Triton8273

    Triton8273 B

    Joined:
    April 27, 2010
    Messages:
    1,147
    Likes Received:
    2
    Trophy Points:
    0
    I had those a while back, reset it and they never came back.
     
  4. waskly

    waskly Well-Known Member

    Joined:
    August 21, 2010
    Messages:
    2,190
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Crooklyn NY!
    do you have an abs light on or check traction control?

    if not clear them.

    if they dont stay cleared, get abs module PMI with an ids.

    if it can't be PMI ( does not accept programming)you need a new abs ecu.
     
  5. armysoldier30263

    armysoldier30263 Active Member

    Joined:
    August 4, 2010
    Messages:
    692
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shaw AFB, SC
    Year, Model & Trim Level:
    05 BLACK 4.0 XLT
    no lights were on ... not even the CEL i just randomly plug in the scanner and found them but yes i cleared them

    and triton did your truck run a little rough when you had the codes? mine seems to have a little hesitation and a little (very little) skip at idle
     
  6. Triton8273

    Triton8273 B

    Joined:
    April 27, 2010
    Messages:
    1,147
    Likes Received:
    2
    Trophy Points:
    0
    I can't quite remember, I had a lot going on with the truck in one month. Had the fuel rail pressure sensor code, cyl 1 misfire, C02 code (due to catback), and then the codes you listed.

    Whenever I get a code that relates to something that isn't easy to check on my own real quick, I just reset it and then if it comes back I will worry. Not much you can do in your case because when I searched those codes I found a lot of possible problems and none of them were anything that I knew anything about.
     
  7. armysoldier30263

    armysoldier30263 Active Member

    Joined:
    August 4, 2010
    Messages:
    692
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shaw AFB, SC
    Year, Model & Trim Level:
    05 BLACK 4.0 XLT
    i erased the codes and will see if they some back ... wiht codes like that i guess thats the only way lol
     

Share This Page







We Support Our Troops!