Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Heater blows mild heat

Discussion in 'A/C & Heater systems - HVAC' started by Pulliam287, December 1, 2016.

^^Searches ExplorerForum.com^^





  1. Pulliam287

    Pulliam287 New Member

    Joined:
    December 1, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Wichita
    Year, Model & Trim Level:
    2003 explorer eddie bauer
    I have on 03 ford explorer eddie bauer I bought from a couple it didn't have any heat. I flushed thw heater core and didn't seem to have aNY blockage, I also removed the heater valve on the hoses and I checked to make sure the blend door actuator was working now I have mild heat but still not hot and with outside temp getting down to 29 deg it takes for ever to feel any heat. does anyone know what else might be wrong I'm going to try to replace the thermostat soon see if that helps.
     
    • Useful Useful x 1
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



Share This Page







We Support Our Troops!