Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Help! Newbie with A/C issues.

Discussion in 'Modified 2002 - 2005 Explorers' started by Mike lyle, May 21, 2018.

^^Searches ExplorerForum.com^^





  1. Mike lyle

    Mike lyle New Member

    Joined:
    May 21, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Santa ana, ca
    Year, Model & Trim Level:
    2003 explorer xlt limited
    Hi all I have a 2003 explorer. Put the A/C ON GOOD GUAGES got a reading of about 27 -28 on each side static. Ac clutch not engaging. Have power to cycle switch connector no power to ac clutch connector.
    Ideas? I'm thinking it should be the switch. Does this switch mount on a shrader valve or do I need to purge the system to replace. Any diagnostic help would be greatly appreciated. Thanks and have a blessed day/evening!
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Joe in NY

    Joe in NY Active Member

    Joined:
    June 5, 2014
    Messages:
    946
    Likes Received:
    75
    Trophy Points:
    38
    City, State:
    Binghamton, NY
    Year, Model & Trim Level:
    2002 Eddie Bauer V8 4X4
    27 to 28 static is an empty system... Switch opens at 28psi and closes around 45. You have a leak
     

Share This Page







We Support Our Troops!