Dismiss Notice



Register Today It's free! This box will disappear once registered!

Help Turn Sigs and brakes lights messed up

Discussion in 'Elite Explorer 911!' started by bhctall1, December 9, 2004.

^^Searches ExplorerForum.com^^
  1. bhctall1

    bhctall1 New Member

    Joined:
    July 16, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    BUllhead City / Laughlin
    Year, Model & Trim Level:
    94 XLT
    Have 94 4x4 4.0 XLT. Whne i depress the brake is the only time the turn sigs come on (when I am moving the turn sig arm on steering colum). Also if I keep the (new) turn sig modual/relay from fuse box in place...everytime i hit the brakes the emergencies come on....so I have pulled the relay, tried new bulbs all round..still a prob..asked a Ford tech..he just got a funny look on his face and mumbled something and laughed.. so any ideas?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.
  3. ashleyroachclip

    ashleyroachclip Active Member

    Joined:
    February 24, 2004
    Messages:
    121
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    Roseburg Oregon
    Year, Model & Trim Level:
    1991 Explorer EB
    I think I would check your emergency flasher ...sounds like there is your problem .....it is on the top of the colomn on my 94 ranger and my 91 x ....good luck
     






We Support Our Troops!