Dismiss Notice



Register Today It's free! This box will disappear once registered!

Help with 05' ford exploer AC...It blows Hot!

Discussion in 'Stock 2002 - 2005 Explorers' started by joewalsh1111, July 25, 2011.

  • Searches ExplorerForum.com
    1. joewalsh1111

      joewalsh1111 New Member

      Joined:
      July 25, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      hi, i just joined the forum to search for help. i own an 2005 explorer
      my a/c blows out hot air, AND my wifes about to have a baby and we need a/c asap!
      at first i thought the ac control switch module may need to be replaced.
      so i replaced it and still blows hot.
      the air has been charged and the compressor and everything works.
      i think hot water is still getting in the coil which is preventing it from cooling, so i clamped off the heater hoses, and the ac started to cool, but i dont have the right tools to keep them clamped off.
      does anyone have pictures of where i can locate the actuator module or the expansion valve? i think if i could find them i could replace them i think they are somewhere under the dash but havnt been able to locate them.


      if anyone has ANY SUGGESTIONS IM MIRE THEN OPEN TO THEM. THANKS ALOT!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Buster34

      Buster34 New Member

      Joined:
      July 24, 2011
      Messages:
      9
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Melbourne, FL
      Year, Model & Trim Level:
      2003 XLT
      Joe,
      One idea is that your mode control is stuck in heat. There is a solinoid on the right hand side of the center console that can be viewed by dropping the glove box. The reason I know this is because I found out today that mine is broken, but fortunately is stuck in the max ac vent mode.
      Drop the glove box down and look up to your left. Then change the HVAC mode control and verify that the solinoid moves in and out and that the lever is attached and also moves.
       
    4. AKbrener

      AKbrener Member

      Joined:
      August 25, 2007
      Messages:
      66
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Dickinson, TX
      Year, Model & Trim Level:
      2005 Explorer Eddie Bauer
      there is also a solenoid/valve on the heater hose that allows the hot water into the heater core/hvac system. it is located on the passenger front side of the motor. just follow the heater hoses from the firewall down to the water pump area. maybe that thing is stuck or the vacuum hose is not connected
       

    Share This Page







    We Support Our Troops!