Dismiss Notice



Register Today It's free! This box will disappear once registered!

Help with Retrofit Source light kit for 2011 Explorer

Discussion in 'Modified 2011- 2019 Explorers - Tuning & Mods' started by Dawgs11Explorer, December 31, 2011.

^^Searches ExplorerForum.com^^





  1. Dawgs11Explorer

    Dawgs11Explorer New Member

    Joined:
    December 31, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Georgia
    Year, Model & Trim Level:
    2011 Explorer XLT
    Live in the Atlanta area and picked up a Retrofit Source light kit just before Christmas. The guys there seemed very cool and they had lots of interesting lighting projects in the works. Anyway, finally had the time to install the kit today and thought I'd followed the directions to a T; they were pretty straight forward and I've done lots of similar projects in the past so was comfortable with the install.

    However, when everything was connected, the lights didn't work. Plugged the factory bulb back in and everything is fine. During the install, am I missing something? Is there a secret to getting these plug and play systems to work; disconnect the battery, a reset you have to do, etc.?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. Dawgs11Explorer

    Dawgs11Explorer New Member

    Joined:
    December 31, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Georgia
    Year, Model & Trim Level:
    2011 Explorer XLT
    Figured out the problem; had to reverse the polarity on the can-bus resistors. All good now, lights look great. Fogs up next.
     
  4. jcerrion

    jcerrion Active Member

    Joined:
    August 10, 2011
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Memphis
    Year, Model & Trim Level:
    2011 Explorer XLT
    can you post some pics? im think about adding some to my XLT.
     
  5. Dawgs11Explorer

    Dawgs11Explorer New Member

    Joined:
    December 31, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Georgia
    Year, Model & Trim Level:
    2011 Explorer XLT
    I'll get some up this weekend. Have a got shot of a side-by-side bulb comparison with the new set up versus old bulbs too.
     

Share This Page







We Support Our Troops!